import re
regex = re.compile(r"@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)", flags=re.MULTILINE)
test_str = ("PQ@Alderaa1:30000!A!->20000\n"
"@Cantonica:3000!D!->4000NM\n\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)