# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<row.*Body=").*?("[^>]+>)/$1$2/g;t' <<< "<row Id=\"9\" Body=\"aaaaaaaaa\" Target=\"123456\" />"