const regex = /(<row.*Body=").*?("[^>]+>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<row.*Body=").*?("[^>]+>)', 'g')
const str = `<row Id="9" Body="aaaaaaaaa" Target="123456" />`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);