import re
regex = re.compile(r"(<row.*Body=\").*?(\"[^>]+>)")
test_str = "<row Id=\"9\" Body=\"aaaaaaaaa\" Target=\"123456\" />"
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)