using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<row.*Body="").*?(""[^>]+>)";
string substitution = @"$1$2";
string input = @"<row Id=""9"" Body=""aaaaaaaaa"" Target=""123456"" />";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}