// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<row.*Body=").*?("[^>]+>)"#).unwrap();
let string = "<row Id=\"9\" Body=\"aaaaaaaaa\" Target=\"123456\" />";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}