use strict;
my $str = '<row Id="9" Body="aaaaaaaaa" Target="123456" />';
my $regex = qr/(<row.*Body=").*?("[^>]+>)/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";