re = /(<row.*Body=").*?("[^>]+>)/
str = '<row Id="9" Body="aaaaaaaaa" Target="123456" />'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result