# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\W+/-/g;t' <<< "Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie"