// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\W+").unwrap();
let string = "Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie";
let substitution = "-";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}