package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\W+`)
var str = `Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie`
var substitution = "-"
fmt.Println(re.ReplaceAllString(str, substitution))
}