import re
regex = re.compile(r"\W+")
test_str = "Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie"
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)