re = /\W+/
str = 'Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result