$re = '/\W+/';
$str = 'Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;