const regex = /\W+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W+', 'g')
const str = `Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);