use strict;
my $str = 'Guitar legends Fender snap up Irish music start-up for 5m - Independent.ie';
my $regex = qr/\W+/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";