# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:([^_]\S*)|_\S+)\.orig$/\1.dest/gm;t' <<< "foo.orig
bar.orig
_baz.orig"