using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([^_]\S*)|_\S+)\.orig$";
string substitution = @"\1.dest";
string input = @"foo.orig
bar.orig
_baz.orig";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}