#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:([^_]\S*)|_\S+)\.orig$"
Local $sString = "foo.orig" & @CRLF & _
"bar.orig" & @CRLF & _
"_baz.orig"
Local $sSubst = "\1.dest"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)