const regex = /^(?:([^_]\S*)|_\S+)\.orig$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:([^_]\\S*)|_\\S+)\\.orig$', 'gm')
const str = `foo.orig
bar.orig
_baz.orig`;
const subst = `\1.dest`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);