import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:([^_]\\S*)|_\\S+)\\.orig$";
final String string = "foo.orig\n"
+ "bar.orig\n"
+ "_baz.orig";
final String subst = "\\1.dest";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}