import Foundation
let pattern = #"^(?:([^_]\S*)|_\S+)\.orig$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foo.orig
bar.orig
_baz.orig
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1.dest"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)