use strict;
my $str = 'foo.orig
bar.orig
_baz.orig';
my $regex = qr/^(?:([^_]\S*)|_\S+)\.orig$/mp;
my $subst = '\\1.dest';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";