re = /^(?:([^_]\S*)|_\S+)\.orig$/m
str = 'foo.orig
bar.orig
_baz.orig'
subst = '\\1.dest'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result