// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:([^_]\S*)|_\S+)\.orig$").unwrap();
let string = "foo.orig
bar.orig
_baz.orig";
let substitution = "\\1.dest";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}