$re = '/^(?:([^_]\S*)|_\S+)\.orig$/m';
$str = 'foo.orig
bar.orig
_baz.orig';
$subst = "\1.dest";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;