package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([^_]\S*)|_\S+)\.orig$`)
var str = `foo.orig
bar.orig
_baz.orig`
var substitution = "\1.dest"
fmt.Println(re.ReplaceAllString(str, substitution))
}