# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\
[ \t]*\
{1,}/\n/gm;t' <<< "testing
- test 1
- test 3
⁃ test 4
• testing
◦ test 2
⁃ tester
- retest
⁃ test
"