using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\
[ \t]*\
{1,}";
string substitution = @"\n";
string input = @"testing
- test 1
- test 3
⁃ test 4
• testing
◦ test 2
⁃ tester
- retest
⁃ test
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}