use strict;
my $str = 'testing
- test 1
- test 3
⁃ test 4
• testing
◦ test 2
⁃ tester
- retest
⁃ test
';
my $regex = qr/\
[ \t]*\
{1,}/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";