# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"\\n"
r"[ \t]*\\n"
r"{1,}")
test_str = ("testing\n\n"
"- test 1\n\n"
"- test 3\n\n"
" ⁃ test 4\n\n"
" • testing\n\n"
" ◦ test 2\n\n"
" ⁃ tester\n\n"
"- retest\n\n"
" ⁃ test\n\n\n")
subst = "\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.