re = /\
[ \t]*\
{1,}/m
str = 'testing
- test 1
- test 3
⁃ test 4
• testing
◦ test 2
⁃ tester
- retest
⁃ test
'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result