// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\
[ \t]*\
{1,}").unwrap();
let string = "testing
- test 1
- test 3
⁃ test 4
• testing
◦ test 2
⁃ tester
- retest
⁃ test
";
let substitution = "\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}