package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\
[ \t]*\
{1,}`)
var str = `testing
- test 1
- test 3
⁃ test 4
• testing
◦ test 2
⁃ tester
- retest
⁃ test
`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}