import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\n"
+ "[ \\t]*\\\n"
+ "{1,}";
final String string = "testing\n\n"
+ "- test 1\n\n"
+ "- test 3\n\n"
+ " ⁃ test 4\n\n"
+ " • testing\n\n"
+ " ◦ test 2\n\n"
+ " ⁃ tester\n\n"
+ "- retest\n\n"
+ " ⁃ test\n\n\n";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}