#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\" & @CRLF & _
"[ \t]*\" & @CRLF & _
"{1,}"
Local $sString = "testing" & @CRLF & _
"" & @CRLF & _
"- test 1" & @CRLF & _
"" & @CRLF & _
"- test 3" & @CRLF & _
"" & @CRLF & _
" ⁃ test 4" & @CRLF & _
"" & @CRLF & _
" • testing" & @CRLF & _
"" & @CRLF & _
" ◦ test 2" & @CRLF & _
"" & @CRLF & _
" ⁃ tester" & @CRLF & _
"" & @CRLF & _
"- retest" & @CRLF & _
"" & @CRLF & _
" ⁃ test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)