import Foundation
let pattern = #"""
\
[ \t]*\
{1,}
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
testing
- test 1
- test 3
⁃ test 4
• testing
◦ test 2
⁃ tester
- retest
⁃ test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)