# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a\s[^>]*href="https:\/\/site\.ru\/[^>]*>(.*?)<\/a>/\1/gis;t' <<< "<a href=\"https://site.ru/*****>слово</a>
<a class=\"m\" href=\"https://site.ru/*****>слово</a>
<a href=\"https://site.ru/*****\" class=\"m\" >слово</a>"