const regex = new RegExp('<a\\s[^>]*href="https://site\\.ru/[^>]*>(.*?)</a>', 'gis')
const str = `<a href="https://site.ru/*****>слово</a>
<a class="m" href="https://site.ru/*****>слово</a>
<a href="https://site.ru/*****" class="m" >слово</a>`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);