import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s[^>]*href=\"https://site\\.ru/[^>]*>(.*?)</a>";
final String string = "<a href=\"https://site.ru/*****>слово</a>\n"
+ "<a class=\"m\" href=\"https://site.ru/*****>слово</a>\n"
+ "<a href=\"https://site.ru/*****\" class=\"m\" >слово</a>";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}