#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?is)<a\s[^>]*href="https://site\.ru/[^>]*>(.*?)</a>"
Local $sString = "<a href="https://site.ru/*****>слово</a>" & @CRLF & _
"<a class="m" href="https://site.ru/*****>слово</a>" & @CRLF & _
"<a href="https://site.ru/*****" class="m" >слово</a>"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)