using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s[^>]*href=""https://site\.ru/[^>]*>(.*?)</a>";
string substitution = @"\1";
string input = @"<a href=""https://site.ru/*****>слово</a>
<a class=""m"" href=""https://site.ru/*****>слово</a>
<a href=""https://site.ru/*****"" class=""m"" >слово</a>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}