re = /<a\s[^>]*href="https:\/\/site\.ru\/[^>]*>(.*?)<\/a>/i
str = '<a href="https://site.ru/*****>слово</a>
<a class="m" href="https://site.ru/*****>слово</a>
<a href="https://site.ru/*****" class="m" >слово</a>'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result