package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<a\s[^>]*href="https://site\.ru/[^>]*>(.*?)</a>`)
var str = `<a href="https://site.ru/*****>слово</a>
<a class="m" href="https://site.ru/*****>слово</a>
<a href="https://site.ru/*****" class="m" >слово</a>`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}