# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a\s[^>]*href=\"https://site\.ru/[^>]*>(.*?)</a>"
test_str = ("<a href=\"https://site.ru/*****>слово</a>\n"
"<a class=\"m\" href=\"https://site.ru/*****>слово</a>\n"
"<a href=\"https://site.ru/*****\" class=\"m\" >слово</a>")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.