import Foundation
let pattern = #"<a\s[^>]*href="https://site\.ru/[^>]*>(.*?)</a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<a href="https://site.ru/*****>слово</a>
<a class="m" href="https://site.ru/*****>слово</a>
<a href="https://site.ru/*****" class="m" >слово</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)