use strict;
my $str = '<a href="https://site.ru/*****>слово</a>
<a class="m" href="https://site.ru/*****>слово</a>
<a href="https://site.ru/*****" class="m" >слово</a>';
my $regex = qr~<a\s[^>]*href="https://site\.ru/[^>]*>(.*?)</a>~isp;
my $subst = '\\1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";