import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^_]*)_(.*)$";
final String string = "Low_pq\n"
+ "High_pq\n"
+ "Low_total_acid_number\n"
+ "High_total_acid_number";
final String subst = "$2_$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}