# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<p>)[\x{0590}-\x{05ff}\x{0600}-\x{06ff}]/<p class="foo">/u;t' <<< "<p>para 1</p><p>نص عربي أو فارسي</p><p>para3</p>"