package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<p>)[\x{0590}-\x{05ff}\x{0600}-\x{06ff}]`)
var str = []byte(`<p>para 1</p><p>نص عربي أو فارسي</p><p>para3</p>`)
var substitution = []byte("<p class="foo">")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}